MS Access Lab 2
Topic: Tables

Summary

. Introduction: Tables, Start to build a new database
Creating Tables: Datasheet View, Design View
Working with Data: Sorting, Filtering
Help on Tables

Introduction

Atable iz a collection of
data about a specific topic,

such as products or suppliers. . Ty
Using a separate tahle for m dabie
each topic means you store
that data only once, which
makes your database
more efficient and reduces
data-entry errors. Tahles
arganize data into

Company Hame
Exatic Liguids

Mewy Orleans Cajun Delights
Grandma Kelly's Homestead
Tokyo Traders

Products : Tahle

columns (called fields) Product Name &| Supplier ID Units in Stock
and rows {called records). .
Chai 1 30
Chang 1 17
Aniseed Syrup 1 13
Carnarvon Tigers 2 53
|

[l A common field relates two tables |

Creating a New Database

First, open MS Access. To build a new database, choose File > New. By selecting New, a
dialog box will pop out, which allows us to create a blank database (with General), or to choose
from other database template wizards (with Databases). For this session, we will focus on
creating a database from a blank one, so choose General > Database.
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Fig. 1: Creating a New Database

Once you created a blank da you will see a dialog box with
seven objects on the left, they are briefly described as follows,
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Tables - a collection of data about a specific topic, such as products or suppliers.
Queries - a command for viewing or analyzing data in different ways or a result of
the command.

Forms - a friendly interface to add a new record

Reports - an object that present data in a organized way according to your
specification. Examples are telephone bills, sales summary etc.

Pages - a web page that has connection to a database. It makes data available on
the Internet or an intranet for interactive reporting, data entry, or data analysis.
Macros - a set of one or more actions that each performs a particular operation,
such as opening a form or printing a report. Macros can help you to automate
common tasks. For example, you can run a macro that prints a report when a user
clicks a command button.

Module - a collection of Visual Basic for Applications declarations and procedures
that are stored together as a unit.
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Creating a Table: Datasheet View

In table Datasheet view, you can add, edit, or view the data in a table. You can also check the spelling
and printyour table's data, filter or sort records, change the datasheet's appearance, or change the
takle's structure by adding or deleting columns.

I Switch views

[ Sort, fiter, or find records |

[ Edit, check spelling, or print_|

l Add or delete records |

Orders : Tahle
File Edit Wienay Inzert Format Records  Toolz  [Window Helgp

WOHERY SRR o @i Y EY MR

Order 1D Customer ID Employee ID Order
10000 | Franchi 5.p.A. Michael Suyama 18-
10001 | Mére Paillarde Laura Callahan 18-
10002 | Folk och fa HB —[Janet Lewverling 19-

10003 | Simons kbistro Laura Callahan 149-

Change the datasheet layout |

I Insert, delete, or rename a column |

There are 2 ways to create a table in Datasheet view:

Go to Insert = Table = Datasheet View

Mew Table |

Design Yiew
Table Wizard
Impart Table
Link Table

Create a new table in
Datasheet view,

(0] 4 I Cancel

Look back at Fig. 2: Dialog Box in Database Window. Click on the Tables - Create
table by creating data

You are then given a Datasheet view with column headings Field1, Field2, and so on, all across
the top of the datasheet. Because the names of each field are not descriptive, you may want to
rename the fields.

Renaming Fields:

1. Place the cursor over the column heading you want to rename and double click. The
column heading will appear highlighted and the cursor will be blinking (you are now in
edit mode)

2. Type the name you want to use and then press the Enter key.




3. Repeat the first two steps for the second column, and so on.
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Fig. 3: Creating a Table in Datasheet View (Renaming Fields)

|Datasheet View

As the column corresponds to the field, the row corresponds to the record. Now we are ready to
add the information. Say that, if we are doing a database of a company, the first table we may
have is Employee. And the fields of Employee may be SSN, LastName, FirstName, and so on.
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LastName FirstName DateofBirth
22 123456739 Smith Jane 11171

23 857654321 Doe John 28465
] a
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Fig. 4 : Datasheet View (Employees: Table)




Create a Table: Design View

Intable Design wiew, ywou can create an entire table from scratch, or add, delete, or customize an existing
table's fields.

l Add or rename afield | [ Set afield's data type |

Products : Table

1 —#  Field Hame Data Type Description
[ Choose a primary key  |—8% | Productio Autotlumber
Productiame Text
P | UnitPrice CUFrEncy
SupplieriD Mumber

Figld Properfies

Zenersl | aokip ' Set field properties |
Forrmat \Currency & |
Decimal Places | Auto |
InfLt Mazk | |

In this view, we can specify detailed properties for each field. This includes the length and type
of information used in the field. But if we were to enter data into the table, we must use
Datasheet View or Forms.

When creating or modifying a table in the Design View, we see a Design Window.

YT — TIP : Click to switch between Datasheet View and Design View =y
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Fig. 5: Design View (Employees: Table)




There are three columns in the top portion of the window. The Field Name is the name of the
fields. For example, SSN, FirstName, LastName. The name for a field must follow MS Access
object-naming rules’. The Data Type is like the domain of an attribute. It provides a list of data
types that we can choose from, including Text, Memo, Number, Date, and so on. The
Description column allows us to describe the field and it is optional. It is always good practice
to be descriptive in your comments. This allows new users to easily understand the
specifications and meaning of your fields. The following table (Table 1) has the description of
each data type.

Setting Type of data Size
(Default) Text or combinations of text | Up to 255 characters or the length
and numbers, as well as numbers that | set by the FieldSize property,
Text don't require calculations, such as whichever is less. Microsoft
phone numbers Access does not reserve space
for unused portions of a text field
Lengthy text or combinations of text Up to 65,535 characters.
Memo
and numbers
Numeric data used in mathematical 1, 2, 4, or 8 bytes (16 bytes if the
Number calculations. FieldSize property is set to
Replication ID).
. Date and time values for the years 8 bytes.
DEETIE 100 through 9999.
Currency values and numeric data 8 bytes.
used in mathematical calculations
involving data with one to four
Currency decimal places. Accurate to 15 digits
on the left side of the decimal
separator and to 4 digits on the right
side.
A unigue sequential (incremented by | 4 bytes (16 bytes if the FieldSize
1) number or random number property is set to Replication ID).
assigned by Microsoft Access
AutoNumber :
whenever a new record is added to a
table. AutoNumber fields can't be
updated.
Yes and No values and fields that 1 bit.
Yes/No contain only one of two values
(Yes/No, True/False, or On/Off).
An object (such as a Microsoft Excel Up to 1 gigabyte (limited by
OLE Object Zpreadsheet, a Microsoft Word available disk space)
ocument, graphics, sounds, or other
binary data) linked to or embedded in

! object-naming rules

A set of specific rules for naming Microsoft Access objects. In Microsoft Access, names can be up to 64
characters long and can include any combination of |etters, numbers, spaces, and specia characters except
aperiod (.), an exclamation point (!), an accent grave (°), and brackets ([ ]). Note that you also can't use
leading spaces or control characters (ASCII values 0 to 31). For information on Visual Basic haming
conventions, search the Help index for "naming conventions.”

Tips

- Avoid including spaces in object names if you'll frequently refer to the objects in expressions or Visual

Basic code.

- Avoid using extremely long names because they are difficult to remember and refer to.




a Microsoft Access table.
Text or combinations of text and Each part of the three parts of a
numbers stored as text and used as a | Hyperlink data type can contain
hyperlink address. The easiest way to | up to 2048 characters.

insert a hyperlink address in a field or
control is to click Hyperlink on the
Insert menu in the datasheet view.

Hyper Link

Creates a field that allows you to The same size as the primary key
choose a value from another table or | field used to perform the lookup,
from a list of values by using a list typically 4 bytes.

box or combo box. Clicking this
option starts the Lookup Wizard,
which creates a Lookup field. After
you complete the wizard, Microsoft
Access sets the data type based on
the values selected in the wizard.

Lookup Wizard

Table 1: Data Type

You can set up properties of fields in the field properties window. The following table has
description of each item in the field properties window.

Field Property Description

Field Size The maximum number of characters you can enter in the field. The
largest maximum you can set is 255.

Format The display layout for the field. Select a pre-defined format or enter a
custom format.

Input Mask A pattern for all data to be entered in the field.

Caption The label for the field when used on a form. If you don't enter a
caption, the field name is used as the label.

Default Value A value that is automatically entered in the field for new records.

Validation Rule An expression that limits the values that can be entered in the field.

Validation Text The error message that appears when you enter a value prohibited
by the validation rule.

Required Specify whether the field is required data entry.

Allow Zero Length Specify whether allow zero-length strings in the field.

Indexed An index speeds up searches and sorting on the field, but may slow
updates. Selecting "Yes - No Duplicates" prohibits duplicate values in
the field.

Table 2:Field Properties

Before we save the table and quit, we need to specify the primary key. In our Employee table,
SSN will be good for primary key. To define SSN as the primary key, click the Field Selector
(shown in Fig. 5) for the SSN field. Field Selector is the gray bar on the left side of the Table
Design grid by each of the fields. When we click here, the whole row appears highlighted. Then

choose Edit, Primary Key or click the Primary Key button (the key symbol # , shown in Fig. 6)
on the toolbar in design view, a key symbol will appear on the Field Selector. Save the table as
Employee. Now we have created one table.?

2 'Y ou can set combination of more than two attributes as a primary key. To do so, first highlight attributes
you wish to set as primary key, and click Primary Key button % in design view.
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Field Name Daka Twpe Description -

|7 | CustomerID Text Unique five-character code based on customer name.,

| |CompanyMame Texk

| |ContactMame Text

|| |ContactTitle Text

|| |Address Text Street or post-office bo,

|| Ciky Text

| |Reqion Text Skate or province.

|| |PostalCode Text

_P / Text

| |Phone Text Phone number includes country code or area code,

| |Fax Text Phone number includes country code or area code,

Field Properties

Genetal | Lookup |
Field Size 15
Farmat

Input Mask.

Caption

Default Yalue
Walidation Rule
Walidation Texk
Required Mo
Allow Zero Length Mo
Indexed o

4 Field name can be up to &4 characters long, inchuding spaces. Press FL
for help on Field names,

[Design view, F6 = Switch panes, F1 = Help, o [ [

Fig. 6: Table Design View

Working with Data

In this section, we will learn how to work with existing data. The sample database file, we will use
in this section is "Northwind.mdb". It is a sample database comes with Microsoft Access. You can
find it in "C:\Program Files\Microsoft Office\Office\Samples\" folder. First, go to the folder and
open "Northwind.mdb" file. And double click "Orders" table to open it.

Sorting Rows

In the Datasheet View, we can sort the records in ascending or descending orders. To sort a
single column, place the cursor anywhere in the column desired. Simply click either the Sort
Ascending or Sort Descending toolbar buttons. We can also right-click and choose Sort
Ascending or Sort Descending from the shortcut menu.

If we want to sort multiple columns, we need to do a little more work. The two columns we want
to sort by must be adjacent to each other; the one that we want to sort by first must be to the left
of the other. Let's work with "Orders" table in "Northwind.mdb" file. Now we will try sorting by
'‘Order Date' then by 'Shipped Date', we must first move 'Shipped Date' column to the left of
'‘Order Date' column. Here are the steps,

1. Highlight the 'Shipped Date' column by clicking the 'Shipped Date' column
heading.

2. Let go of the mouse button and then press it again, holding it this time.

3. Now drag the 'Shipped Date' column over the 'Required Date' column. When we
get just to the right of the 'Order Date', let up on the mouse button. Then 'Order
Date' and 'Shipped Date' should sit side by side now.




4. Click the mouse button on the '‘Order Date' header, highlighting the column. Holding
the mouse button down, drag it over the 'Shipped Date' column so that both the
'Order Date' and 'Shipped Date' columns appear highlighted.

5. Click on Records - Sort & Sort Ascending
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[ | [Order ID Customer Employee Order Date | Shipped Date | Required Dz
[ 10248 %ins et alcools Chevalier Buchanan, Steven 04-Jul- 1956 16-Jul-1996 01-Aug-1%
L |* 10249 Toms Spezialitdten Suyama, Michael 05-Jul-1995 10-Jul-19596 16-Aug-1¢
|+ 10250 Hanari Carnes Peacock, Margaret 08-Jul-1996 12-Jul-1996 05-Aug-15
[ 10251 Wictuailles en stock Leverling, Janet 08-Jul-1996 15-Jul-1996 05-Aug-15
[ 10252 Suprémes délices FPeacock, Margaret 03-Jul-1995 11-Jul-1956 0B-Aug-15_
= 10253 Hanarti Carnes Leverling, Janet 10-Jul- 1996 16-Jul-1996 24-Jul-1¢
e 10254 Chop-suey Chinese Buchanan, Steven 11-Jul-1996 23-Jul-1996 08-Aug-1t
RAE: 10255 Richter Supermarkt Dodswarth, Anne 12-Jul-1936 15-Jul{1996 03-Aug-1¢
| 10256 Wellington Importadora Leverling, Janet 15-Jul-1996 17-Jul-1996 12-Aug-18
| |* 10257 HILARION-Abastos Peacock, Margaret 16-Jul-1996 22-Jul-1996 13-Aug-18
N 10255 Ernst Handel Davolio, Mancy 17-Jul-1936 23-Jul-1995 14-Aug-1¢
L= 10259 Centro comercial Moctezuma Peacock, Margaret 18-Jul-1996 25-Jul-1996 15-Aug-1¢
[ 10260 Ottilies Kaseladen Peacock, Margaret 19-Jul-1996 29-Jul-1996 16-Aug-18
& + 10261 Que Delicia Peacock. Margaret 19-Ju|-19?6 30-Jul-1995 16-Auu1jl|
!Datasheet View |_ l_ [_ I_ |_ W l_ |_ S

Fig. 7: Northwind Database: Sort Result

Filters

By using Filter by Selection, you tell Access that you want to see only certain records, based on
the value in the field in which the cursor currently resides. For example, say that we want to see
those orders shipped in Germany. To do this,

1. Inthe 'Ship Country' column, click a field that has "Germany" in this field.

2. Click the right button of mouse and select "Filter by Selection” button. Or, you may
click Records button in the menu bar and select Filter button and select Filter by
Selection. Only those records that have Germany for their Ship Country appear.

3. Click the right button again and select "Remove Filter" button to remove the filter.

With Filter by Selection, you were filtering records based on a field you selected in the
datasheet, and then selected another field in the subset to narrow it further. When using Filter
by Form, Access takes you to a different screen to specify the criteria you want to filter with.
Using Filter by Form, although more complicated, allows you to be more specific and filter your
data based on a combination of selected values from multiple fields. To do this,

1. click on Records - Filter > Filter by Form

2. The datasheet will suddenly look as if you deleted all the records. Now you can
pick the fields you want to filter and display your information.

3. Click OrderID field to see the drop-down list. You can use =, >, <, >=, and <= to
specify your criteria.

4. Finally, click on Filter > Apply Filter to see the result.

Finally, we will see how to use AND and OR criterion in a filter. The AND operator allows you to
filter records based on two or more criteria. When you apply a filter using the AND operator, only
those records that meet both (or all) criteria appear. To show how to use the AND operator, we
will choose all orders shipped in USA AND freight is above $100. To do this,




Click the Filter by Form button to return to the Filter by Form screen. The screen
should be blank.

Click Ship Country and select USA.

Click Freight and type ">100" (without quotation mark).

Click the Apply Filter button. Now those orders shipped in USA and freight is above
$100 will appear. (there should be 40 records)

To show all the orders which is either shipped in USA OR whose freight is over $100, follow the

steps,

N

Click the Record menu.

Select Filter in the roll down menu and choose Filter by Form.

Press the right mouse button on any field and choose Clear Grid button.(this clears
all previous filters’ parameters)

Click Ship Country and select "USA". As soon as you enter the first criteria, Access
enables an OR tab at the bottom of the Filter by Form.

Click the Or tab at the bottom of the Filter by Form screen.

Click freight and type ">100" (without quotation mark).

Press the right mouse button in any field and a menu will pop up. Click the Apply
Filter button. Now those orders that are either shipped in USA or whose freight is
over $100 will appear. (there should be 269 records)

CONGRATULATIONS ! You have learned the basics of creating and manipulating tables of data




